Microservices
374 items from mfornos/awesome-microservices ★14,541
-
CBOR cbor.io
Concise Binary Object Representation (RFC 8949), a binary data format with a JSON-like data model designed for small message sizes and constrained devices.
-
RSocket rsocket.io
RSocket is a binary protocol for use on byte stream transports such as TCP, WebSockets, and Aeron.
-
Reactive Streams reactive-streams.org
Standard for asynchronous stream processing with non-blocking back pressure.
-
Cap’n Proto capnproto.org
Insanely fast data interchange format and capability-based RPC system.
-
Nomad nomadproject.io
HashiCorp Nomad is a single binary that schedules applications and services on Linux, Windows, and Mac. It is an open source scheduler that uses a declarative job file for scheduling virtualized, containerized, and standalone applications.
-
Cloud Native Computing Foundation cncf.io
The Cloud Native Computing Foundation will create and drive the adoption of a new set of common container technologies informed by technical merit and end user value, and inspired by Internet-scale computing.
-
ØMQ zeromq.org
Brokerless intelligent transport layer.
-
Zenoh zenoh.io
Pub/sub/query protocol unifying data in motion, data at rest and computations. Efficiently blends traditional pub/sub with geo distributed storage, queries and computations.
-
WireMock wiremock.org
Flexible library for stubbing and mocking web services. Unlike general purpose mocking tools it works by creating an actual HTTP server that your code under test can connect to as it would a real web service.
-
MiniApp White Paper w3c.github.io
MiniApp standardization white paper.
-
W3C.REC-Webarch w3.org
Architecture of the World Wide Web, Volume One.
-
DID w3.org
W3C specification of Decentralized identifiers (DIDs): a new type of identifier that enables verifiable, decentralized digital identity.
-
Cereal uscilab.github.io
C++11 library for serialization.
-
Finatra twitter.github.io
Fast, testable, Scala HTTP services built on Twitter-Server and Finagle.
-
Twisted twisted.org
Event-driven network programming engine.
-
Tornado tornadoweb.org
Web framework and asynchronous networking library.
-
RFC7807 tools.ietf.org
Problem Details for HTTP APIs.
-
RFC7644 tools.ietf.org
SCIM: Protocol, an application-level, REST protocol for provisioning and managing identity data on the web.
-
RFC7643 tools.ietf.org
SCIM: Core Schema, provides a platform-neutral schema and extension model for representing users and groups.
-
RFC7642 tools.ietf.org
SCIM: Definitions, overview, concepts, and requirements.
-
RFC7540 tools.ietf.org
Hypertext Transfer Protocol Version 2.
-
RFC7519 tools.ietf.org
JSON Web Token (JWT) is a compact, URL-safe means of representing claims to be transferred between two parties.
-
RFC7515 tools.ietf.org
JSON Web Signature (JWS) represents content secured with digital signatures or Message Authentication Codes (MACs) using JSON-based data structures.
-
RFC7320 tools.ietf.org
URI Design and Ownership.
-
RFC7235 tools.ietf.org
Authentication.
-
RFC7234 tools.ietf.org
Caching.
-
RFC7233 tools.ietf.org
Range Requests.
-
RFC7232 tools.ietf.org
Conditional Requests.
-
RFC7231 tools.ietf.org
Semantics and Content.
-
RFC7230 tools.ietf.org
Message Syntax and Routing.
-
RFC7049 tools.ietf.org
Concise Binary Object Representation (CBOR).
-
RFC6962 tools.ietf.org
Certificate transparency.
-
RFC6749 tools.ietf.org
The OAuth 2.0 authorization framework.
-
RFC6570 tools.ietf.org
URI Template.
-
RFC6347 tools.ietf.org
Datagram Transport Layer Security Version 1.2.
-
RFC6066 tools.ietf.org
TLS Extensions.
-
RFC5246 tools.ietf.org
The Transport Layer Security (TLS) Protocol Version 1.2.
-
RFC4627 tools.ietf.org
JavaScript Object Notation (JSON).
-
RFC3986 tools.ietf.org
Uniform Resource Identifier (URI): Generic Syntax.
-
RFC3629 tools.ietf.org
UTF-8, a transformation format of ISO 10646.
-
QUIC-Transport tools.ietf.org
A UDP-based multiplexed and secure transport.
-
Tokio tokio.rs
Asynchronous runtime for writing network applications.
-
Symfony symfony.com
Micro-framework based on the Symfony components.
-
Spiral spiral.dev
Framework designed for long-running applications using RoadRunner. It offers advanced features like integration with the Temporal workflow engine and Centrifugo websocket server. It is particularly effective for microservices architecture, providing robust support for REST APIs…
-
Specmatic specmatic.io
Converts API specifications (OpenAPI, AsyncAPI, GraphQL, gRPC etc) into executable contracts for automated testing, service virtualisation, and backward compatibility validation without writing code.
-
SmallRye smallrye.io
APIs and implementations tailored for cloud development, including Eclipse MicroProfile.
-
Slim slimframework.com
Micro-framework that helps you quickly write simple yet powerful web applications and APIs.
-
SkyWalking skywalking.apache.org
Application performance monitor tool for distributed systems, especially designed for microservices, cloud native and container-based (Docker, K8s, Mesos) architectures.
-
SCIM simplecloud.info
System for Cross-domain Identity Management.
-
Riemann riemann.io
Monitors distributed systems.
- next page of items loading…