Microservices
374 items from mfornos/awesome-microservices ★14,541
-
Twitter Finagle twitter.github.io
asynchronous network stack for the JVM.
-
Trino trino.io
distributed SQL query engine for querying large datasets across heterogeneous data sources.
-
Serf serf.io
decentralized solution for service discovery and orchestration.
-
Apache Mesos mesos.apache.org
cluster manager.
-
Apache Helix helix.apache.org
cluster management framework.
-
Graylog graylog.org
log management platform for collecting, storing, searching, and alerting on machine data.
-
Kibana elastic.co
visualize logs and time-stamped data
-
RabbitMQ rabbitmq.com
Robust messaging for applications.
-
Apache Pulsar pulsar.apache.org
An open-source distributed pub-sub messaging system.
-
Akka Toolkit akka.io
runtime for distributed, and fault tolerant event-driven applications on the JVM.
-
Aerospike aerospike.com
NoSQL flash-optimized, in-memory. Open source and "Server code in 'C' (not Java or Erlang) precisely tuned to avoid context switching and memory copies."
-
Apache Ignite ignite.apache.org
High-performance, integrated and distributed in-memory platform for computing and transacting on large-scale data sets in real-time, orders of magnitude faster than possible with traditional disk-based or flash technologies.
-
Cloud Native Landscape landscape.cncf.io
Interactive landscape of cloud native technologies.
-
Tengine Web Server tengine.taobao.org
A distribution of Nginx with some advanced features.
-
apiblueprint apiblueprint.org
Tools for your whole API lifecycle. Use it to discuss your API with others. Generate documentation automatically. Or a test suite. Or even some code.
-
RxJS reactivex.io
API for asynchronous programming with observable streams. Available for idiomatic Java, Scala, C#, C++, Clojure, JavaScript, Python, Groovy, JRuby, and others.
-
Vertx vertx.io
Vert.x is a lightweight, high performance application platform for the JVM
-
Spring-Boot projects.spring.io
Spring Boot makes it easy to create stand-alone, production-grade Spring based Applications that can you can "just run". Use Groovy as your coding language.
-
Micronaut micronaut.io
A brand new microservices framework created by the Grails team
-
vibe.d vibed.org
Asynchronous I/O that doesn’t get in your way, written in D.
-
Sinatra sinatrarb.com
Sinatra is a DSL for quickly creating web applications in Ruby with minimal effort.
-
nsq nsq.io
A realtime distributed messaging platform.
-
Gleam gleam.run
A friendly language for building type-safe, scalable systems.
-
Pact docs.pact.io
The de-facto standard for consumer-driven contract testing, with implementations in most major languages and a broker for sharing contracts between teams.
-
CBOR cbor.io
Concise Binary Object Representation (RFC 8949), a binary data format with a JSON-like data model designed for small message sizes and constrained devices.
-
RSocket rsocket.io
RSocket is a binary protocol for use on byte stream transports such as TCP, WebSockets, and Aeron.
-
Reactive Streams reactive-streams.org
Standard for asynchronous stream processing with non-blocking back pressure.
-
Cap’n Proto capnproto.org
Insanely fast data interchange format and capability-based RPC system.
-
Nomad nomadproject.io
HashiCorp Nomad is a single binary that schedules applications and services on Linux, Windows, and Mac. It is an open source scheduler that uses a declarative job file for scheduling virtualized, containerized, and standalone applications.
-
Cloud Native Computing Foundation cncf.io
The Cloud Native Computing Foundation will create and drive the adoption of a new set of common container technologies informed by technical merit and end user value, and inspired by Internet-scale computing.
-
ØMQ zeromq.org
Brokerless intelligent transport layer.
-
Zenoh zenoh.io
Pub/sub/query protocol unifying data in motion, data at rest and computations. Efficiently blends traditional pub/sub with geo distributed storage, queries and computations.
-
Start with Team Cognitive Load - Team Topologies youtube.com
small_red_triangle:YT - DOES19 London. The "monoliths vs microservices" debate often focuses on technological aspects, ignoring strategy and team dynamics. Instead of technology, smart-thinking organizations are beginning with team cognitive load as the guiding principle for…
-
WireMock wiremock.org
Flexible library for stubbing and mocking web services. Unlike general purpose mocking tools it works by creating an actual HTTP server that your code under test can connect to as it would a real web service.
-
MiniApp White Paper w3c.github.io
MiniApp standardization white paper.
-
W3C.REC-Webarch w3.org
Architecture of the World Wide Web, Volume One.
-
DID w3.org
W3C specification of Decentralized identifiers (DIDs): a new type of identifier that enables verifiable, decentralized digital identity.
-
Cereal uscilab.github.io
C++11 library for serialization.
-
Finatra twitter.github.io
Fast, testable, Scala HTTP services built on Twitter-Server and Finagle.
-
Twisted twisted.org
Event-driven network programming engine.
-
Tornado tornadoweb.org
Web framework and asynchronous networking library.
-
RFC7807 tools.ietf.org
Problem Details for HTTP APIs.
-
RFC7644 tools.ietf.org
SCIM: Protocol, an application-level, REST protocol for provisioning and managing identity data on the web.
-
RFC7643 tools.ietf.org
SCIM: Core Schema, provides a platform-neutral schema and extension model for representing users and groups.
-
RFC7642 tools.ietf.org
SCIM: Definitions, overview, concepts, and requirements.
-
RFC7540 tools.ietf.org
Hypertext Transfer Protocol Version 2.
-
RFC7519 tools.ietf.org
JSON Web Token (JWT) is a compact, URL-safe means of representing claims to be transferred between two parties.
-
RFC7515 tools.ietf.org
JSON Web Signature (JWS) represents content secured with digital signatures or Message Authentication Codes (MACs) using JSON-based data structures.
-
RFC7320 tools.ietf.org
URI Design and Ownership.
-
RFC7235 tools.ietf.org
Authentication.
- next page of items loading…