Microservices
374 items from mfornos/awesome-microservices ★14,541
-
RFC7234 tools.ietf.org
Caching.
-
RFC7233 tools.ietf.org
Range Requests.
-
RFC7232 tools.ietf.org
Conditional Requests.
-
RFC7231 tools.ietf.org
Semantics and Content.
-
RFC7230 tools.ietf.org
Message Syntax and Routing.
-
RFC7049 tools.ietf.org
Concise Binary Object Representation (CBOR).
-
RFC6962 tools.ietf.org
Certificate transparency.
-
RFC6749 tools.ietf.org
The OAuth 2.0 authorization framework.
-
RFC6570 tools.ietf.org
URI Template.
-
RFC6347 tools.ietf.org
Datagram Transport Layer Security Version 1.2.
-
RFC6066 tools.ietf.org
TLS Extensions.
-
RFC5246 tools.ietf.org
The Transport Layer Security (TLS) Protocol Version 1.2.
-
RFC4627 tools.ietf.org
JavaScript Object Notation (JSON).
-
RFC3986 tools.ietf.org
Uniform Resource Identifier (URI): Generic Syntax.
-
RFC3629 tools.ietf.org
UTF-8, a transformation format of ISO 10646.
-
QUIC-Transport tools.ietf.org
A UDP-based multiplexed and secure transport.
-
Tokio tokio.rs
Asynchronous runtime for writing network applications.
-
Symfony symfony.com
Micro-framework based on the Symfony components.
-
Spiral spiral.dev
Framework designed for long-running applications using RoadRunner. It offers advanced features like integration with the Temporal workflow engine and Centrifugo websocket server. It is particularly effective for microservices architecture, providing robust support for REST APIs…
-
Specmatic specmatic.io
Converts API specifications (OpenAPI, AsyncAPI, GraphQL, gRPC etc) into executable contracts for automated testing, service virtualisation, and backward compatibility validation without writing code.
-
SmallRye smallrye.io
APIs and implementations tailored for cloud development, including Eclipse MicroProfile.
-
Slim slimframework.com
Micro-framework that helps you quickly write simple yet powerful web applications and APIs.
-
SkyWalking skywalking.apache.org
Application performance monitor tool for distributed systems, especially designed for microservices, cloud native and container-based (Docker, K8s, Mesos) architectures.
-
SCIM simplecloud.info
System for Cross-domain Identity Management.
-
Riemann riemann.io
Monitors distributed systems.
-
Microservices – Please, don’t riak.com
Critical advice about some problems regarding a microservices approach.
-
ROCAS resources.1060research.com
small_orange_diamond:PDF - Resource Oriented Computing for Adaptive Systems.
-
Reactive Manifesto reactivemanifesto.org
Reactive systems definition.
-
Ratpack ratpack.io
Set of Java libraries that facilitate fast, efficient, evolvable and well tested HTTP applications. specific support for the Groovy language is provided.
-
Raft Consensus raft.github.io
Consensus algorithm that is designed to be easy to understand. It's equivalent to Paxos in fault-tolerance and performance.
-
QUIC-WG quicwg.org
IETF Working Group that is chartered to deliver the next transport protocol for the Internet.
-
Quarkus quarkus.io
A Kubernetes Native Java stack tailored for OpenJDK HotSpot and GraalVM, crafted from the best of breed Java libraries and standards.
-
Pulumi pulumi.io
SDK for cloud native infrastructure as code. Use your favorite language to preview and manage updates to your apps and infrastructure, and continuously deploy to any cloud (no YAML required).
-
Spring REST Docs projects.spring.io
Document RESTful services by combining hand-written documentation with auto-generated snippets produced with Spring MVC Test.
-
Poco pocoproject.org
C++ class libraries for building network-based applications and servers.
-
Play playframework.com
The high velocity web framework for Java and Scala.
-
Phoenix phoenixframework.org
Framework for building HTML5 apps, API backends and distributed systems.
-
PASETO paseto.io
Paseto is everything you love about JOSE (JWT, JWE, JWS) without any of the many design deficits that plague the JOSE standards. DRAFT
-
Otoroshi otoroshi.io
Modern HTTP reverse proxy with lightweight API management.
-
Microservice Antipatterns and Pitfalls oreilly.com
Microservice mostly known antipatterns and pitfalls.
-
Open Service Mesh openservicemesh.io
Lightweight and extensible cloud native service mesh.
-
OpenResty openresty.org
Fast web application server built on top of Nginx.
-
Open Liberty openliberty.io
A lightweight open framework for building fast and efficient cloud-native Java microservices.
-
OIDCONN openid.net
OpenID Connect 1.0 is a simple identity layer on top of the OAuth 2.0 protocol. It allows clients to verify the identity of the end-user based on the authentication performed by an Authorization Server, as well as to obtain basic profile information about the end-user in an…
-
OpenID Connect openid.net
Libraries, products, and tools implementing current OpenID specifications and related specs.
-
Open RPC open-rpc.org
The OpenRPC Specification defines a standard, programming language-agnostic interface description for JSON-RPC 2.0 APIs.
-
OAuth oauth.net
Provides specific authorization flows for web applications, desktop applications, mobile phones, and living room devices. Many implementations.
-
NATS nats.io
Open source, high-performance, lightweight cloud messaging system.
-
Your Server as a Function monkey.org
small_orange_diamond:PDF - Describes three abstractions which combine to present a powerful programming model for building safe, modular, and efficient server software: Composable futures, services and filters.
-
Moleculer moleculer.services
Fast & powerful microservices framework for Node.js, Java, Go and Ruby.
- next page of items loading…