dogear

enter for all results · esc to close

Programming

Software development: programming languages, coding, libraries and frameworks, software engineering and architecture, source control, developer tools, databases, and infrastructure.

  1. Wikipedia: PD software en.wikipedia.org

    List of PD software on Wikipedia.

  2. Using CC0 for Public Domain Software creativecommons.org

    Drawbacks of using CC0 to license computer programs.

  3. Char Bit charb.it

    Writings about JavaScript from a full stack developer with 20 years of experience.

  4. Ryan Boren boren.blog

    Lead developer of WordPress at Automattic.

  5. Billy Shih billyshih.com

    Blog of a web developer at Full Circle.

  6. Web Components dev.to

    For the Web Monetization API (serie).

  7. FLOSS Weekly 150 twit.tv

    Interview with the developer.

  8. Practical Services Monitoring with Prometheus and Docker web.archive.org

    Practical services monitoring with Prometheus and Docker by Simon KP.

  9. Prometheus and Kubernetes: A Perfect Match weave.works

    Part 1 of 3 in the series Prometheus and Kubernetes.

  10. Prometheus and Kubernetes: Deploying weave.works

    Part 2 of 3 in the series Prometheus and Kubernetes.

  11. Prometheus and Kubernetes: Monitoring Your Applications weave.works

    Part 3 in the series Prometheus and Kubernetes.

  12. Kubernetes monitoring with Prometheus, the ultimate guide sysdig.com

    Kubernetes monitoring with Prometheus, the ultimate guide by Mateo Burillo.

  13. Setting up Prometheus Monitoring On a Kubernetes Cluster spacelift.io

    Setting up Prometheus Monitoring On a Kubernetes Cluster by James Walker.

  14. Prometheus Monitoring with Brian Brazil softwareengineeringdaily.com

    Brian Brazil on the Software Engineering Daily podcast.

  15. System Monitoring with Prometheus slideshare.net

    Brian Brazil at Devops Ireland Meetup, Dublin.

  16. Docker daemon metrics in Prometheus medium.com

    Docker daemon metrics in Prometheus by Luc Juggery.

  17. Horizontal Pod Autoscaling in Kubernetes with Prometheus livewyer.io

    Horizontal Pod Autoscaling in Kubernetes with Prometheus by Louise.

  18. How To Install Prometheus using Docker on CentOS 7 digitalocean.com

    Walkthrough on how to install Prometheus on CentOS 7.

  19. Monitor your GitHub Repos with Docker and Prometheus brianchristner.io

    Monitor your GitHub Repos with Docker and Prometheus.

  20. Monitor Docker Containers with Prometheus 5pi.de

    Using Prometheus to monitor Docker containers.

  21. Yireo Training yireo.com

    Magento 2 backend and frontend development courses.

  22. Jisse Reitsma yireo.com

    Vice President of the Magento Association; 3x Magento Master; founder of Yireo; trainer on Hyva, GraphQL, and Loki Checkout; Mage-OS Open Source Task Force member.

  23. Willem Poortman wpoortman.nl

    Senior Developer at Hyva Themes; creator of the Magewire framework for server-side Magento 2 components.

  24. Mark Shust markshust.com

    Creator of markshust/docker-magento (the most-starred Magento-specific GitHub repo); educator at M.academy with 600+ video lessons.

  25. magento.watch magento.watch

    Release dates, end-of-life dates and system requirements for every Magento, Adobe Commerce and Mage-OS version, with a free JSON API.

  26. Magento Stack Exchange magento.stackexchange.com

    Q&A site for users and developers of the Magento e-Commerce platform.

  27. Mage-OS Association mage-os.org

    The community alliance ensuring the accessibility, longevity, and success of Magento Open Source.

  28. M Bytes Newsletter m.academy

    🫡 - Weekly developer newsletter from M.academy delivering three free Magento video lessons every Thursday.

  29. Willem Wigman hyva.io

    Founder and CEO of Hyva Themes; creator of the Hyva frontend framework for Magento 2; released Hyva as open source in November 2025.

  30. ExtDN extdn.org

    A network of leading Magento extension developers committed to quality and best practices.

  31. Adobe PWA Studio developer.adobe.com

    Adobe's headless React frontend. GraphQL client; offers Venia theme, Peregrine hooks, Buildpack (Webpack) and UPWARD (SSR/image middleware).

  32. Magento Developer Documentation devdocs.magento.com

    Official developer documentation.

  33. Voltra voltra.co

    DRM-free music listening and discovery software that supports artists directly.

  34. Liberapay liberapay.com

    Open source recurring donations platform.

  35. left-pad pypi.python.org

    Python's solution to infamous npm problem.

  36. Fapfap.js fapfapjs.io

    Handcrafted JavaScript framework for DIY enthusiasts.

  37. Twisted twisted.org

    Event-driven network programming engine.

  38. RFC7807 tools.ietf.org

    Problem Details for HTTP APIs.

  39. RFC7643 tools.ietf.org

    SCIM: Core Schema, provides a platform-neutral schema and extension model for representing users and groups.

  40. RFC7642 tools.ietf.org

    SCIM: Definitions, overview, concepts, and requirements.

  41. RFC7515 tools.ietf.org

    JSON Web Signature (JWS) represents content secured with digital signatures or Message Authentication Codes (MACs) using JSON-based data structures.

  42. RFC4627 tools.ietf.org

    JavaScript Object Notation (JSON).

  43. Spiral spiral.dev

    Framework designed for long-running applications using RoadRunner. It offers advanced features like integration with the Temporal workflow engine and Centrifugo websocket server. It is particularly effective for microservices architecture, providing robust support for REST APIs…

  44. Specmatic specmatic.io

    Converts API specifications (OpenAPI, AsyncAPI, GraphQL, gRPC etc) into executable contracts for automated testing, service virtualisation, and backward compatibility validation without writing code.

  45. SmallRye smallrye.io

    APIs and implementations tailored for cloud development, including Eclipse MicroProfile.

  46. Slim slimframework.com

    Micro-framework that helps you quickly write simple yet powerful web applications and APIs.

  47. SkyWalking skywalking.apache.org

    Application performance monitor tool for distributed systems, especially designed for microservices, cloud native and container-based (Docker, K8s, Mesos) architectures.

  48. Raft Consensus raft.github.io

    Consensus algorithm that is designed to be easy to understand. It's equivalent to Paxos in fault-tolerance and performance.

  49. Quarkus quarkus.io

    A Kubernetes Native Java stack tailored for OpenJDK HotSpot and GraalVM, crafted from the best of breed Java libraries and standards.

  50. next page of items loading…