dogear

enter for all results · esc to close

Cross-App Access (XAA), formally known as the "Identity Assertion Authorization Grant"

datatracker.ietf.orgsite

Enables AI agents and apps to securely access and act across multiple services with user consent using standardized and fine-grained OAuth permissions.

from
OpenID Connect
added
2026-10-10
likes
0

similar

  1. OAuth oauth.net

    Provides specific authorization flows for web applications, desktop applications, mobile phones, and living room devices. Many implementations.

    site link ↗
  2. GNAP datatracker.ietf.org

    Grant Negotiation and Authorization Protocol defines a mechanism for delegating authorization to a piece of software, and conveying that delegation to the software. This delegation can include access to a set of APIs as well as information passed directly to the software.DRAFT

  3. OAuth 2.0 for First-Party Applications datatracker.ietf.org

    Defines the Authorization Challenge Endpoint to enable native applications to obtain user authorization through native user interfaces.

    site link ↗
  4. OAuth 2.0 App2App Browserless Flow github.com

    Describing a protocol enabling native navigation across apps performing authentication using the App2App pattern, without requiring a web browser.

    tool link ↗
  5. authgate github.com

    A lightweight OAuth 2.0 Authorization Server supporting Device Authorization Grant (RFC 8628), Authorization Code Flow with PKCE (RFC 6749 + RFC 7636), and Client Credentials Grant for machine-to-machine authentication.

    tool link ↗
  6. azureappconfiguration github.com

    The configuration provider for consuming data in Azure App Configuration from Go applications.

    tool link ↗

OpenID Connect › Resources > Specifications > Draft: “Enables AI agents and apps to securely access and act across multiple services with user consent using standardized and fine-grained OAuth permissions.”