dogear

enter for all results · esc to close

GNAP

datatracker.ietf.orgsite

Grant Negotiation and Authorization Protocol defines a mechanism for delegating authorization to a piece of software, and conveying that delegation to the software. This delegation can include access to a set of APIs as well as information passed directly to the software.DRAFT

from
Microservices
added
2026-10-10
likes
0

similar

  1. authgate github.com

    A lightweight OAuth 2.0 Authorization Server supporting Device Authorization Grant (RFC 8628), Authorization Code Flow with PKCE (RFC 6749 + RFC 7636), and Client Credentials Grant for machine-to-machine authentication.

    tool link ↗
  2. Cross-App Access (XAA), formally known as the "Identity Assertion Authorization Grant" datatracker.ietf.org

    Enables AI agents and apps to securely access and act across multiple services with user consent using standardized and fine-grained OAuth permissions.

  3. NAP nap-framework.tech

    site link ↗
  4. OAuth oauth.net

    Provides specific authorization flows for web applications, desktop applications, mobile phones, and living room devices. Many implementations.

    site link ↗
  5. EQGRP github.com

    tool link ↗

Microservices › Standards / Recommendations > Security: “Grant Negotiation and Authorization Protocol defines a mechanism for delegating authorization to a piece of software, and conveying that delegation to the software. This delegation can include access to a set of APIs as well as information passed directly to the software.DRAFT”