dogear

enter for all results · esc to close

authgate

github.comtool

A lightweight OAuth 2.0 Authorization Server supporting Device Authorization Grant (RFC 8628), Authorization Code Flow with PKCE (RFC 6749 + RFC 7636), and Client Credentials Grant for machine-to-machine authentication.

from
Go
added
2026-10-10
likes
0

similar

  1. oauth2 github.com

    Successor of goauth2. Generic OAuth 2.0 package that comes with JWT, Google APIs, Compute Engine, and App Engine support.

  2. yup-oauth2 github.com

    An oauth2 client implementation providing the Device, Installed and Service Account flows

  3. goiabada github.com

    An open-source authentication and authorization server supporting OAuth2 and OpenID Connect.

  4. agentgateway (⭐5.1k) github.com

    An open-source data plane for agentic AI connectivity, providing security, observability, and governance for agent-to-tool (MCP) and agent-to-agent (A2A) communication.

  5. Authelia github.com

    🆓 Open-source authentication and authorization server providing two-factor authentication and single sign-on (SSO) for your applications via a web portal.

  6. go-guardian github.com

    Go-Guardian is a golang library that provides a simple, clean, and idiomatic way to create powerful modern API and web authentication that supports LDAP, Basic, Bearer token, and Certificate based authentication.

Go › Authentication and Authorization: “A lightweight OAuth 2.0 Authorization Server supporting Device Authorization Grant (RFC 8628), Authorization Code Flow with PKCE (RFC 6749 + RFC 7636), and Client Credentials Grant for machine-to-machine authentication.”