yup-oauth2
An oauth2 client implementation providing the Device, Installed and Service Account flows
- from
- Rust
- added
- 2026-10-10
- likes
- 0
similar
-
-
oxide-auth github.com
A OAuth2 server library, for use in combination with actix or other frontends, featuring a set of configurable and pluggable backends
-
goth github.com
provides a simple, clean, and idiomatic way to use OAuth and OAuth2. Handles multiple providers out of the box.
-
authgate github.com
A lightweight OAuth 2.0 Authorization Server supporting Device Authorization Grant (RFC 8628), Authorization Code Flow with PKCE (RFC 6749 + RFC 7636), and Client Credentials Grant for machine-to-machine authentication.
-
-
oauth2 github.com
Successor of goauth2. Generic OAuth 2.0 package that comes with JWT, Google APIs, Compute Engine, and App Engine support.
Rust › Libraries > Authentication: “An oauth2 client implementation providing the Device, Installed and Service Account flows”