dogear

enter for all results · esc to close

Programming Languages

22,646 items in 77 lists

  1. net golang.org

    This repository holds supplementary Go networking libraries.

    site link ↗
  2. go modules golang.org

    Modules are the unit of source code interchange and versioning. The go command has direct support for working with modules, including recording and resolving dependencies on other modules.

  3. GoLab golab.io

    Florence, Italy.

    site link ↗
  4. GoDays godays.io

    Berlin, Germany.

    site link ↗
  5. gocql gocql.github.io

    Go language driver for Apache Cassandra.

    site link ↗
  6. GoCon gocon.connpass.com

    Tokyo, Japan.

    site link ↗
  7. Go By Example gobyexample.com

    Hands-on introduction to Go using annotated example programs.

    site link ↗
  8. goblin goblin.run

    Cloud builder for CLI's written in go lang

    site link ↗
  9. Go 101 go101.org

    A book focusing on Go syntax/semantics and all kinds of details.

  10. Awesome Go @LibHunt go.libhunt.com

    Your go-to Go Toolbox.

    site link ↗
  11. Go Proverbs go-proverbs.github.io

    Go Proverbs by Rob Pike.

    site link ↗
  12. gilbert go-gilbert.github.io

    Build system and task runner for Go projects.

    site link ↗
  13. Go database/sql tutorial go-database-sql.org

    Introduction to database/sql.

  14. blanket gitlab.com

    blanket is a tool that helps you catch functions which don't have direct unit tests in your Go packages.

    site link ↗
  15. go-formatter gitlab.com

    Implements replacement fields surrounded by curly braces {} format strings.

    site link ↗
  16. errors gitlab.com

    Providing errors with a stack trace and optional structured details. Compatible with github.com/pkg/errors API but does not use it internally.

  17. go-telegraph gitlab.com

    Telegraph publishing platform API client.

  18. genmock gitlab.com

    Go mocking system with code generator for building calls of the interface methods.

    site link ↗
  19. uniq gitlab.com

    No hassle safe, fast unique identifiers with commands.

    site link ↗
  20. Squalus gitlab.com

    Thin layer over the Go SQL package that makes it easier to perform queries.

  21. pjrpc gitlab.com

    Golang JSON-RPC Server-Client with Protobuf spec.

  22. re2dfa gitlab.com

    Transform regular expressions into finite state machines and output Go source code.

    site link ↗
  23. slogor gitlab.com

    A colorful slog handler.

    site link ↗
  24. cli gitlab.com

    An open-source GitLab command line tool bringing GitLab's cool features to your command line.

    site link ↗
  25. Pnutmux gitlab.com

    Pnutmux is a powerful Go web framework that uses regex for matching and handling HTTP requests. It offers features such as CORS handling, structured logging, URL parameters extraction, middlewares, and concurrency limiting.

    site link ↗
  26. cosban/di gitlab.com

    A code generation based dependency injection wiring tool.

    site link ↗
  27. dyndns gitlab.com

    Background Go process to regularly and automatically check your IP Address and make updates to (one or many) Dynamic DNS records for Google domains whenever your address changes.

    site link ↗
  28. go-yapla gitlab.com

    Go client library for the Yapla v2.0 API.

  29. Uber github.com

    site link ↗
  30. Trending Go repositories on GitHub today github.com

    Good place to find new Go libraries.

    site link ↗
  31. nurago/pkg/redact github.com

    Removes secrets from log lines and HTTP dumps in a single pass, covering headers, JSON, XML, URL-encoded data, JWTs, PEM keys, and vendor tokens.

    site link ↗
  32. asyncmachine-go/pkg/machine github.com

    Graph control flow library (AOP, actor, state-machine).

    site link ↗
  33. gone/log github.com

    Fast, extendable, full-featured, std-lib source compatible log library.

    site link ↗
  34. gone/jconf github.com

    Modular JSON configuration. Keep your config structs along with the code they configure and delegate parsing to submodules without sacrificing full config serialization.

    site link ↗
  35. go-test-coverage github.com

    A GitHub Action which reports issues when test coverage is below set threshold.

    site link ↗
  36. gommon/color github.com

    Style terminal text.

    site link ↗
  37. bytes github.com

    Formats and parses numeric byte values (10K, 2M, 3G, etc.).

    site link ↗
  38. gob github.com

    Gradle/Maven like build tool for Go projects.

    tool link ↗
  39. Hyperledger github.com

    site link ↗
  40. hiboot cli github.com

    cli application framework with auto configuration and dependency injection.

    site link ↗
  41. bexp github.com

    Go implementation of Brace Expansion mechanism to generate arbitrary strings.

    site link ↗
  42. Go Projects github.com

    List of projects on the Go community wiki.

    site link ↗
  43. soda github.com

    Database migration, creation, ORM, etc... for MySQL, PostgreSQL, and SQLite.

  44. go-openapi github.com

    Collection of packages to parse and utilize open-api schemas.

  45. authgate github.com

    A lightweight OAuth 2.0 Authorization Server supporting Device Authorization Grant (RFC 8628), Authorization Code Flow with PKCE (RFC 6749 + RFC 7636), and Client Credentials Grant for machine-to-machine authentication.

    tool link ↗
  46. staticcheck github.com

    staticcheck is go vet on steroids, applying a ton of static analysis checks you might be used to from tools like ReSharper for C#.

    site link ↗
  47. CockroachDB github.com

    site link ↗
  48. IntelliJ IDEA Plugin plugins.jetbrains.com

    site link ↗
  49. Book pest.rs

    The recommended way to start parsing with pest is to read this official book.

  50. fiddle editor on pest.rs pest.rs

    Play with grammars and share them on the official website (and format them!).

    site link ↗
  51. next page of items loading…