Go
3,166 items from avelino/awesome-go ★187,948
-
Trending Go repositories on GitHub today github.com
Good place to find new Go libraries.
-
nurago/pkg/redact github.com
Removes secrets from log lines and HTTP dumps in a single pass, covering headers, JSON, XML, URL-encoded data, JWTs, PEM keys, and vendor tokens.
-
asyncmachine-go/pkg/machine github.com
Graph control flow library (AOP, actor, state-machine).
-
gone/log github.com
Fast, extendable, full-featured, std-lib source compatible log library.
-
gone/jconf github.com
Modular JSON configuration. Keep your config structs along with the code they configure and delegate parsing to submodules without sacrificing full config serialization.
-
go-test-coverage github.com
A GitHub Action which reports issues when test coverage is below set threshold.
-
gommon/color github.com
Style terminal text.
-
bytes github.com
Formats and parses numeric byte values (10K, 2M, 3G, etc.).
-
gob github.com
Gradle/Maven like build tool for Go projects.
-
Hyperledger github.com
-
hiboot cli github.com
cli application framework with auto configuration and dependency injection.
-
bexp github.com
Go implementation of Brace Expansion mechanism to generate arbitrary strings.
-
Go Projects github.com
List of projects on the Go community wiki.
-
soda github.com
Database migration, creation, ORM, etc... for MySQL, PostgreSQL, and SQLite.
-
go-openapi github.com
Collection of packages to parse and utilize open-api schemas.
-
authgate github.com
A lightweight OAuth 2.0 Authorization Server supporting Device Authorization Grant (RFC 8628), Authorization Code Flow with PKCE (RFC 6749 + RFC 7636), and Client Credentials Grant for machine-to-machine authentication.
-
staticcheck github.com
staticcheck is go vet on steroids, applying a ton of static analysis checks you might be used to from tools like ReSharper for C#.
-
CockroachDB github.com
-
Trybe github.com
-
VarHandler github.com
Generate boilerplate http input and output handling.
-
XORM gitea.com
Simple and powerful ORM for Go. (Support: MySQL, MyMysql, PostgreSQL, Tidb, SQLite3, MsSql and Oracle).
-
zs git.mills.io
an extremely minimal static site generator.
-
Bitcask git.mills.io
Bitcask is an embeddable, persistent and fast key-value (KV) database written in pure Go with predictable read/write performance, low latency and high throughput thanks to the bitcask on-disk layout (LSM+WAL).
-
gitea-github-migrator git.jonasfranz.software
Migrate all your GitHub repositories, issues, milestones and labels to your Gitea instance.
-
gio gioui.org
Gio is a library for writing cross-platform immediate mode GUI-s in Go. Gio supports all the major platforms: Linux, macOS, Windows, Android, iOS, FreeBSD, OpenBSD and WebAssembly.
-
Golang Tutorial Guide freecodecamp.org
A List of Free Courses to Learn the Go Programming Language.
-
Go Forum forum.golangbridge.org
Forum to discuss Go.
-
mqttPaho eclipse.org
The Paho Go Client provides an MQTT client library for connection to MQTT brokers via TCP, TLS or WebSockets.
-
GitLab docs.gitlab.com
-
Golang Weekly discu.eu
Each monday projects, tutorials and articles about Go.
-
How To Code in Go eBook digitalocean.com
A 600 page introduction to Go aimed at first time developers.
-
Understanding Go in a visual way dev.to
Learn Go visually
-
Learning Go by examples dev.to
Series of articles in order to learn Golang language by concrete applications as example.
-
Programming with Google Go coursera.org
Coursera Specialization to learn about Go from scratch.
-
Confetti Framework confetti-framework.github.io
Confetti is a Go web application framework with an expressive, elegant syntax. Confetti combines the elegance of Laravel and the simplicity of Go.
-
Writing A Compiler In Go compilerbook.com
-
Coding Mystery codingmystery.com
Solve exciting escape-room-inspired programming challenges using Go.
-
CodinGame codingame.com
Learn Go by solving interactive tasks using small games as practical examples.
-
Code with Mukesh codewithmukesh.com
Software Engineer and Blogs @ codewithmukesh.com.
-
Building Web Apps With Go codegangsta.gitbooks.io
-
enra/go-styleguide codeberg.org
-
goal codeberg.org
An embeddable scripting array language.
-
swift code.pfad.fr
Offline validity check of IBAN (International Bank Account Number) and retrieval of BIC (for some countries).
-
pglock cirello.io
PostgreSQL-backed distributed locking implementation.
-
dynamolock cirello.io
DynamoDB-backed distributed locking implementation.
-
Learn Go Programming blog.learngoprogramming.com
Learn Go concepts with illustrations.
-
Spaceship Go A Journey to the Standard Library blasrodri.github.io
-
The Power of Go: Tools bitfieldconsulting.com
A guide to writing command-line tools in Go.
-
The Power of Go: Tests bitfieldconsulting.com
A guide to testing in Go.
-
For the Love of Go bitfieldconsulting.com
An introductory book for Go beginners.
- next page of items loading…